Monday, April 15, 2013

Cisco - Port settings


L2 trunk port (802.1q)

interface FastEthernet3/43
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 30
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
 switchport nonegotiate
 no shutdown

L2 Access port (porcurve untagged port)

interface FastEthernet3/43
 no ip address
 duplex full
 speed 100
 switchport
 switchport access vlan 10
 switchport mode access

interface FastEthernet3/48
 no ip address
 switchport
 switchport access vlan 1
 switchport mode access

interface Vlan10
 ip address 10.1.1.1 255.255.255.0

interface Vlan1
 ip address 13.28.236.10 255.255.240.0


switchport host

Normally I would enable spanning-tree portfast on all access ports to ensure they come up quicker, and also set them to access ports.

This command does 3 things!
·         Configures the switchport for access mode
·         Enables portfast
·         Disables Etherchannel

Switch1(config)# interface range fa0/1 – 48
Switch(config-if-range)# switchport host
switchport mode will be set to access
spanning-tree portfast will be enabled
channel group will be disabled

switchport voice vlan

Syntax: switchport voice vlan {dot1p | none | untagged | vlan-id}

The options used with the switchport voice vlan command are as follows:
Option
Description
dot1p
It sends CDP packets that configure the IP phone to transmit voice traffic in the default VLAN in 802.1p frames that are tagged with a Layer 2 CoS value.
none
It allows the IP phone to use its own configuration and transmit untagged voice traffic in the default VLAN.
untagged
It sends CDP packets that configure the IP phone to transmit untagged voice traffic in the default VLAN.
vlan-id
It sends CDP packets that configure the IP phone to transmit voice traffic in the voice VLAN in 802.1Q frames that are tagged with a Layer 2 CoS value.

AutoQoS supports Cisco IP phones with the auto qos voip cisco-phone interface configuration command. When you enter the auto qos voip cisco-phone interface configuration command on a port that is configured to support an IP phone and to which an IP phone is connected, the autoQoS feature does the following:
If QoS was not already enabled, enables QoS globally.
If VLAN-based QoS was configured for the port, reverts to the default port-based QoS (done for all ports on switching modules with 1p1q0t/1p3q1t ports).
Sets the port trust state to trust CoS.
Creates and applies a trust-CoS QoS policy to ports on switching modules with non-Gigabit Ethernet 1q4t/2q2t ports, which do not support port trust.

aaa authentication login default local


·         This means router will use local username & password to authenticate.

No comments:

Post a Comment

Please add comments so I may update the material to accommodate platform modification to various commands. Also if you have some real-world caveats, do please share.

Search Duke

About the Author

My photo
Central Florida, United States